cave_canem_lj (cave_canem0) wrote in ru_mac,
cave_canem_lj
cave_canem0
ru_mac

Господам программерам и не только - libiconv.2.dylib

Здравствуйте!
Недавно при входе в терминал появилось следующее:

MacBook:~ ed$ bash
dyld: Library not loaded: /opt/local/lib/libiconv.2.dylib
  Referenced from: /opt/local/bin/bash
  Reason: Incompatible library version: bash requires version 8.0.0 or later, but libiconv.2.dylib provides version 7.0.0

Делал:

brew update
Trace/BPT trap: 5
MacBook:~ ed$ brew update
error: unable to unlink old '.gitignore' (Operation not permitted)
error: unable to unlink old 'CONTRIBUTING.md' (Operation not permitted)
error: unable to unlink old 'README.md' (Operation not permitted)
error: unable to unlink old 'SUPPORTERS.md' (Operation not permitted)
error: unable to unlink old 'bin/brew' (Operation not permitted)
error: unable to unlink old 'share/man/man1/brew.1' (Operation not permitted)
Error: Failure while executing: git pull -q origin refs/heads/master:refs/remotes/origin/master

MacBook:~ ed$ brew install libiconv
Error: No available formula for libiconv
Apple distributes libiconv with OS X, you can find it in /usr/lib.
Some build scripts fail to detect it correctly, please check existing
formulae for solutions.

Как это победить?
Спасибо.
Tags: os x (системные вопросы), terminal|console
Subscribe
  • Post a new comment

    Error

    Comments allowed for members only

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 2 comments